[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFC: some new deb package flag: "upgrade-conflicts"

On Tue, Oct 01, 2002 at 09:16:16PM +0200, Simon Richter wrote:

> "upgradeable skipping one release" is basically what happens if you
> provide upgrade paths from oldstable and stable to the current version,
> which is IMO the minimum. The maximum of what should be supported is
> determined by the amount of cruft in the maintainer scripts building up by
> supporting upgrades from previous versions.

The upgrade path from oldstable to stable+1 is to upgrade to stable first.
There is no justification to place unnecessary workload on package
maintainers just to save users from taking this step.

 - mdz

Reply to: