[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: State of automake packages



On Wed, Jun 05, 2002 at 10:42:03PM +0100, Andrew Suffield wrote:
> On Wed, Jun 05, 2002 at 09:58:47PM +0100, Scott James Remnant wrote:
> > If an application was written to use automake 1.4 or before, automake
> > 1.4 is the latest version of automake you can use to generate the
> > Makefile.ins for it.  This is the majority of applications, and will
> > probably remain so for quite some time.
> 
> FWIW, all the Makefile.am's I have ever written (created mostly with
> automake 1.4), many of which are quite sophisticated, have worked fine
> with automake 1.5 (or at least as well as they did with 1.4). Most of
> the problems I've seen stem from attempts at "workarounds" for things
> which automake blatantly does not support (like building source files
> which are located in directories other than the one where Makefile.am
> is located).

I see the same thing too.  My Makefile.ams work fine with 1.4x and 1.5.  I
did have to remove some ugly hacks that broke automake 1.5, but since then
they work with either.

> Haven't tried the versions which haven't made it into debian yet,
> though.

They work fine with 1.6x too.  Once you use 1.5/1.6 features, 1.4
obviously breaks, but I have never seen unsolvable backwards compatibility
problems.

-- 
Roger Leigh
                ** Registration Number: 151826, http://counter.li.org **
                Need Epson Stylus Utilities? http://gimp-print.sourceforge.net/
                GPG Public Key: 0x25BFB848 available on public keyservers

Attachment: pgpEh8EqU1NHT.pgp
Description: PGP signature


Reply to: