[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: .dsc not generated during package build?

> > Since it was trying to tar up 'icu' (which is a symlink) for whatever
> > reason, it may be that dpkg-source tried to create a tarfile containing
> only
> > that.  dpkg-source just does a "tar cf -", so symlinks would not be
> > followed.  I could see how that might have caused some confusion.
> > I agree that an error should have been reported somewhere during this
> > process if a .dsc was not created, so if you can track down where the
> > problem is, there may be a bug report in it.
> Nope, this is not the case.  I generally have a <pkg> symlink pointing to
> <pkg>-<ver>, and it has always worked fine for me.

I tried that and it works.

But have you tried having a <pkg> symlink pointing to
<ver-or-other>/<pkg>-<ver>? That's what I have (icu -> 2.0/icu-2.0) and it
definitely confuses the build. I tried changing:




in dpkg-buildpackage but then I get:

if test -d build -a build != source; then rm -f -r build; fi
 dpkg-source -b icu-2.0
dpkg-source: error: cannot stat directory ./icu-2.0: No such file or


Reply to: