[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#127252: -unstable compiled against the wrong libpng

On Thu, Jan 03, 2002 at 04:19:02PM -0700, Ivan E. Moore II wrote:
> On Thu, Jan 03, 2002 at 04:41:59PM -0600, Colin Watson wrote:
> > If a bug I filed had been treated that way, I would have reopened it
> > immediately. Closing a bug out of hand just because you don't agree with
> > where it has been filed is completely wrong.
> first off the package "kde" is a meta package that has no binaries so
> there is absolutely no problem with that package.  The bug report was closed
> with a comment of "file it against the proper packages please".  What is
> so wrong about this?  Absolutely nothing.  

'bts reassign 127215 libqt2'

... since it was clearly libqt2 breaking backward compatibility.

Anyway, I've run out of time for this evidently pointless discussion,
unless you're willing to have the technical committee comment, in which
case I will attempt to write up a summary.

> I don't have the time to sit there and file bug reports on behalf of a user.
> Especially since the problem is known and is being dealt with.

It's being dealt with by breaking partial upgrades rather than reverting
the thing that actually caused the breakage. From the bug report:

| Much of kde stopped working when the libpng verson changed and qt2 was
| updated to start using it.                     

Anyway, I've said what I think of this strategy elsewhere.

Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: