[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#127252: -unstable compiled against the wrong libpng



This issue is fixed in kmerlin_0.3.1-5_i386, which has been uploaded.

Btw, this appears to be a major backwards incompatibily problem
between libpng2 -> 3 which effects lots and lots of packages.
The solution is rather simple, requiring recompilation to
get the correct linkage to libpng3, but it would of been nice to
see some dicussion on debian-devel before the upload of
libpng3 to unstable 'broke' all our pacakges.

Mark

On Mon, Dec 31, 2001 at 10:30:31PM +0100, Jasper Spaans wrote:
> Package: kmerlin
> Version: 0.3.1-4
> Severity: important
> 
> When running the binary of kmerlin found in -unstable, I get the following
> errors, and no icons are displayed:
> 
> libpng error: Incompatible libpng version in application and library
> libpng warning: Application was compiled with png.h from libpng-1.2.1
> libpng warning: Application  is running with png.c from libpng-1.0.12
> 
> Fetching the source and recompiling against the newest libpng-dev solves
> this problem; my list of installed png-libraries:
> 
> ii  libpng-dev     1.2.1-1        PNG library - development
> ii  libpng2        1.0.12-3       PNG library - runtime
> ii  libpng3        1.2.1-1        PNG library - runtime
> 
> Furthermore, looking at the ldd-output for kmerlin:
> 
> 	libpng.so.2 => /usr/lib/libpng.so.2 (0x40d9b000)
> 
> for the precompiled binary; for the /recompiled/ binary:
> 
> 	libpng.so.3 => /usr/lib/libpng.so.3 (0x40dc6000)
> 
> So in theory, this should work correctly; maybe this dependency problem has
> something to do with kde's way of loading dynamic libs.
> 
> -- 
> Jasper Spaans
> http://jsp.ds9a.nl/contact/
> Tel/Fax: +31-84-8749842
> 

Attachment: pgpTUfidAxrYY.pgp
Description: PGP signature


Reply to: