[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sorry, broken packages



Hi folks!

I'm new at this ML and hoping, that I'll not make a fool of myself ;)

Using: Debian testing/sid (since 1 yr)
(Linux for 5 yrs)

Since a few weeks, I noticed, that I can't install something with e.g.
apt-get because of broken packages.

Yes, I _did_ use "apt-get update" and "[U]pdate" within dselect too ;)

No, I don't have a cron-job with "apt-get dist-update" in it. I make it by
hand every few months or so.

Though I uses apt-get and dselect over one year without havin troubles yet,
I am confused of the recent troubles. Especially because they didn't vanish
by waiting for a couple of weeks (hoped that maintainers will fix the bugs 
anyway).

Our local linux-newsgroup couldn't help me and so I address the experts
here:

Is that _my_ problem or are there many broken dependencies in sid?


lisa:~# apt-get -su install something
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
 
Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:
 
Sorry, but the following packages have unmet dependencies:
  abiword: Conflicts: abi-fonts but it is not installable
           Conflicts: abisuite but it is not installable
           Conflicts: abiword-xml but it is not installable
           Conflicts: abiword-expat but it is not installable
           Conflicts: abiword-common but it is not installable
  communicator-smotif-476:  ddd: Conflicts: ddd-dmotif but it is not
installable
E: Sorry, broken packages
lisa:~#

OK, get rid of that abiword:

lisa:~# dpkg -P abiword
(Reading database ... 94535 files and directories currently installed.)
Removing abiword ...
Purging configuration files for abiword ...
lisa:~#

but:

lisa:~# apt-get -su install something
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
 
Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:
 
Sorry, but the following packages have unmet dependencies:
  cracklib2: Conflicts: cracklib2.6 but it is not installable
  ddd: Conflicts: ddd-dmotif but it is not installable
  debconf: Conflicts: apt (< 0.3.12.1) but 0.5.3 is to be installed
           Conflicts: cdebconf (< 0.10-5) but it is not going to be
installed
  emacs20: Conflicts: w3-el but it is not installable
  g++:  libgimp1.1: Conflicts: libgimp1.1.3 but it is not installable
              Conflicts: libgimp1.1.6 but it is not installable
              Conflicts: libgimp1.1.7 but it is not installable
              Conflicts: libgimp1.1.9 but it is not installable
              Conflicts: libgimp1.1.12 but it is not installable
              Conflicts: libgimp1.1.14 but it is not installable
              Conflicts: libgimp1.1.24 but it is not installable
  libmpeglib0: Conflicts: task-kdemultimedia but it is not installable
  python-imaging: Conflicts: pil but it is not installable
                  Conflicts: python-pil but it is not installable
E: Sorry, broken packages
lisa:~#

and so on :(

I also used dselect and the main problem there seems to be that
apache-common requires a apache-perl packet with a version-number that
doesn't exist yet. (Again, since a couple of weeks!)

Hope, that someone can give me a hint what I should do to fix these problems.

-- 
Karl VOIT
           Karl@Voit.net
           Graz University of Technology (Austria/Europe)
           Linux - because it works. (mostly ;)

Attachment: pgpPEqWAC8KK2.pgp
Description: PGP signature


Reply to: