Re: apt got messed up
On Sun, 10 Jun 2001 01:53:26 BST, Oliver wrote:
> $ sudo apt-get -f -u upgrade
> 389 packages upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
> Sorry, but the following packages have unmet dependencies:
> apache-dev: Depends: apache-common (>= 1.3.19) but 1.3.19-1 is to be installed
> bbdb: Depends: make but 3.79.1-6 is to be installed
> blas-dev: Depends: blas1 (= 1.0-6) but 1.0-6 is to be installed
> blas1: Conflicts: lapack (<= 3.0-1) but 3.0-5.1 is to be installed
> bluefish: Depends: zlib1g (>= 1:1.1.3) but 1:1.1.3-15 is to be installed
> libgtkhtml7: Depends: libaudiofile0 but 0.2.1-0.1 is to be installed
> Depends: libgal6 but 0.7-2 is to be installed
> Depends: libgnomeui32 (>= 1.2.13-5) but 1.2.13-6 is to be installed
> Depends: libunicode0 (>= 0.4.0-2) but 0.4.0-2 is to be installed
> Depends: oaf (>= 0.6.5) but 0.6.5-5 is to be installed
> E: Internal Error, InstallPackages was called with broken packages!
> First, the dependencies complained of seem to be fine. Second, what can
> I do to get it working again?
Try "apt-get --fix-broken dist-upgrade" I'm assuming that you are using
woody. I went several months without an upgrade, and ran into similar
problems as you are expiriencing. I've come to the conclusion that it may
be best to use dist-upgrade whenever upgrading a machine running testing,
but I may be wrong.
If my above suggestion does not work try:
"apt-get --fix-missing install dpkg apt"
this should entice apt to upgrade the package handling tools in case the
packages causing you trouble want newer versions.
then run "apt-get --fix-missing dist-upgrade"
I'm not sure about your specific situation but the above solution should
clear up a number of upgrade dependancy problems. At least it will do no
Paul T. Wright <firstname.lastname@example.org>
-currently seeking employment-