apt got messed up
$ sudo apt-get -f -u upgrade
389 packages upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
Sorry, but the following packages have unmet dependencies:
apache-dev: Depends: apache-common (>= 1.3.19) but 1.3.19-1 is to be installed
bbdb: Depends: make but 3.79.1-6 is to be installed
blas-dev: Depends: blas1 (= 1.0-6) but 1.0-6 is to be installed
blas1: Conflicts: lapack (<= 3.0-1) but 3.0-5.1 is to be installed
bluefish: Depends: zlib1g (>= 1:1.1.3) but 1:1.1.3-15 is to be installed
libgtkhtml7: Depends: libaudiofile0 but 0.2.1-0.1 is to be installed
Depends: libgal6 but 0.7-2 is to be installed
Depends: libgnomeui32 (>= 1.2.13-5) but 1.2.13-6 is to be installed
Depends: libunicode0 (>= 0.4.0-2) but 0.4.0-2 is to be installed
Depends: oaf (>= 0.6.5) but 0.6.5-5 is to be installed
E: Internal Error, InstallPackages was called with broken packages!
First, the dependencies complained of seem to be fine. Second, what can
I do to get it working again?
Oliver Elphick Oliver.Elphick@lfix.co.uk
Isle of Wight http://www.lfix.co.uk/oliver
PGP: 1024R/32B8FAA1: 97 EA 1D 47 72 3F 28 47 6B 7E 39 CC 56 E4 C1 47
GPG: 1024D/3E1D0C1C: CA12 09E0 E8D5 8870 5839 932A 614D 4C34 3E1D 0C1C
"Verily, verily, I say unto you, He that heareth my
word, and believeth on him that sent me, hath
everlasting life, and shall not come into
condemnation; but is passed from death unto life."