[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Broken Star Office in unstable?

rob@debianplanet.org wrote:
> On Wed, Apr 11, 2001 at 01:29:20AM -0700, Erik Steffl wrote:
> > Rob Bradford wrote:
> > >
> > > Is is interesting, i've been running the first release of Open Office on
> > > woody/sid which is basically Star Office with some stuff ripped out and
> > > although it does crash sometimes, it never does it very regularly.
> > >
> > > Maybe you could look at that ....
> >
> >   I just tried staroffice in unstable and it does not work with X
> > server, it works fine when displayed on different computer or usig vnc
> > (even if both vnc server and vnc viewer are on the same machine). It
> > does not work even if I run it on different computer just display it on
> > unstable.
> Myabe its built against XFree86 v3 libs which is having problems with the
> 4 ?

  it works on testing/X 4.x with tdfx driver, does not work on
unstable/X 4.x savage driver (I have newer savage driver, 1.1.15 because
the one included with X did not work)

  I can run staroffice fine on both systems, but I can only display it
on voodoo3 system. it might be some bug in savage driver... what's
confusing is that all other programs work, staroffice is so far the only
program I have problems with (on savage machine)

  it looks like on the system where it works it runs with all the
standard (X 4.x) X libraries:

jojda:~...diag/mii-diag>ldd /opt/office52/program/soffice.bin
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40025000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x40070000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40085000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40093000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x4016d000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40176000)
        libdl.so.2 => /lib/libdl.so.2 (0x4018c000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4018f000)
        libm.so.6 => /lib/libm.so.6 (0x401a5000)
        libc.so.6 => /lib/libc.so.6 (0x401c4000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

> The original post stated that it crashed on loading ..

  well, this one does not exactly crash... it does not work either
though... might be different manifestation of same problem... or
completely different problem...


Reply to: