[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-depends on archaic versions of software wrong!

Christian Marillat wrote in gnome-core's changelog:
>   * Build depends on versionned gettext 0.10.35-17 (Closes: #93198)

Bug #93198 should be reopened, then.
Packages uploaded to unstable *must* compile using packages in unstable.

The "right" fix would be to obtain a fixed .po file from the translator.

A good workaround (until a fixed translation arrives) would be to
make the wrong msgstr entries empty. This is easy to do if you read
the logs for the failed build carefully. For example, in sawfish, you
can easily modify the ko.po file so that it reads:

#. ../lisp/sawfish/wm/windows.jl
msgid ""
"Offset (%) from top window edge when warping pointer.\n"
"A negative number means outside the top window edge."
msgstr ""

You can also remove the .po file completely, but IMHO, this would be an
undeserved punishment for Korean users of sawfish.

Reply to: