[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-depends on archaic versions of software wrong!

>>>> "SV" == Santiago Vila <sanvila@unex.es> writes:

SV> Christian Marillat wrote in gnome-core's changelog:
>> * Build depends on versionned gettext 0.10.35-17 (Closes: #93198)

SV> Bug #93198 should be reopened, then.
SV> Packages uploaded to unstable *must* compile using packages in unstable.

SV> The "right" fix would be to obtain a fixed .po file from the translator.

Quoting the latest "Minutes of the GNOME Advisory Board Meeting"

"    Main problem in 1.4 is I18N support, and cannot be done in a binary"
"    compatible fashion."
"    Having an 1.4.1 release is planned but not firmly, and a-priori only"
"    a bug fix."

I translate "this will be fixed in 6 months, maybe".

This wild never ready for woody.

SV> A good workaround (until a fixed translation arrives) would be to
SV> make the wrong msgstr entries empty. This is easy to do if you read
SV> the logs for the failed build carefully. For example, in sawfish, you
SV> can easily modify the ko.po file so that it reads:

SV> #. ../lisp/sawfish/wm/windows.jl
SV> msgid ""
SV> "Offset (%) from top window edge when warping pointer.\n"
SV> "\n"
SV> "A negative number means outside the top window edge."
SV> msgstr ""

SV> You can also remove the .po file completely, but IMHO, this would be an
SV> undeserved punishment for Korean users of sawfish.

But removing wrong msgstr isn't realy nice.


Reply to: