[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PRE Version numbers

In Tue, 16 Jan 2001 00:18:06 +1000 Anthony Towns <aj@azure.humbug.org.au> cum veritate scripsit :

> $ dpkg --compare-versions '1.4-0pre2-1' '<<' '1.4-1'; echo $?
> 1
> Apparently dpkg treats 1.4-0pre2-1 as greater than 1.4-1, so this
> wouldn't work...

I guess, 1.4-0.pre2-1 would be the solution...
It doesn't look that nice, but it is what it is.

Also some people seem to use

1.3+1.4pre2-1 etc.

This seems to work too... 

It'd be nice if there was something in the developers
manual because this discussion seems to come up in debian-devel
from time to time.


University: ti0113@mail4.doshisha.ac.jp    Netfort: dancer@netfort.gr.jp
                                            Debian: dancer@debian.org 
dancer, a.k.a. Junichi Uekawa   http://www.netfort.gr.jp/~dancer
 Dept. of Knowledge Engineering and Computer Science, Doshisha University.

Reply to: