[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libpq.a (postgresql-dev) Malfored archive

I was trying to custom compile apache-1.3.12(-2.2) and received the
following error (with postgresql[-dev] 7.0.3-1 installed):

gcc -shared -o mod_auth_pgsql.so
mod_auth_pgsql.o -Wl,/usr/lib/libpq.a -lc -lm -lcrypt -ldb
/usr/lib/libpq.a: could not read symbols: Malformed archive
collect2: ld returned 1 exit status
apxs:Break: Command failed with rc=1

Tried to compile apache-1.3.14 and had the same problem ..
I then recompiled postgresql and reinstalled... same problem ..

Bug in postgresql-dev ?


Reply to: