[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel-package or kernel-source needs libncurses-devel

On Fri, Apr 14, 2000 at 01:08:26PM -0500, Steve Greenland wrote:
> Dselect's overly aggressive handling of Recommends is already painful.

Just because one tool is broken it doesn't mean others shouldn't implement
it correctly.

> Apt-get should just grab the "depends" level dependencies. If you want
> "recommends" and "suggests" dependencies recognized, use a higher level
> tool (e.g. dselect, console-apt, aptitude).

How high does that level have to be to be able to fetch a recommended
package? apt-get (and related) already does everything one would ever want
to do with packages, it just doesn't have a GUI but a CLI.

A configuration option for auto-getting recommended packages (in apt.conf)
would suffice for now, I think.

Digital Electronic Being Intended for Assassination and Nullification

Reply to: