[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: frozen libc6 wierdness

A friend of mine can't get his potato machine upgraded to woody as a result
of this --- he has been trying to run apt-get upgrade every day for the last
two weeks, with no positive effects.

Does anyone have plans for fixing this thing? Do people still know it is

Thanks... :)

On Tue, Feb 01, 2000 at 11:17:59PM -0700, Jason Gunthorpe wrote:
> Package: libgtk1.2
> Version: 1.2.6-1
> Severity: important
> On Tue, 1 Feb 2000, Seth R Arnold wrote:
> > In any event, I rather like many of the packages apt suggested
> > uninstalling, so I am not sure upgrading is really the right thing to
> > do, but releasing potato in a state where the newest libc6 libraries
> > conflict with so many useful packages, it just seems wrong.
> It appears APT is unable to resolve the forced removal of gconv-modules
> and the substitution of locales. Regrettably, I don't think this is
> something APT is going to be able to do in the future at all, it is a
> highly complicated.. The dependency relations look something like this:
>               /-> gconv-modules -\
> libgtk1.2 -> ??            ^      +-> (conflict) libc6
>      |        \-> locales -| (conflict)            | (depend+conflict!)
>      ----------------------------------------------+
> Lots of nice circles and the bizzar use of | causes the paradoxical
> depending and not-depending on libc6 simultaneously!
> I think the primary way to fix this problem is to fix up the depends line
> of libgtk1.2:
> Depends: gconv-modules | libc6 (<< 2.1), libc6, libc6 (>= 2.1), libglib1.2
>                          (>= 1.2.0), xlib6g (>= 3.3.4-1)
>     Mentioning libc6 3 times is really, really lame and I think that the
>     fact it is in the failing | group is the primary cause of this
>     problem.
>     Thus the identical depends line:
> Depends: gconv-modules, libc6 (> 2.1), libglib1.2 (>= 1.2.0), xlib6g(>= 3.3.4-1)
>     Should be used instead!
> Ideally, to really stamp this out libgtk1.2 would directly depend on
> locales (Joel??) for potato. However, I have a feeling just fixing that |
> group will make it go away!
> Any other packages that use the above rediculous construct should also be
> fixed as well!!
> This bug gets to be important for two primary reasons:
>   1) Old APTs freak out when they see this in a really strange and scary
>      way
>   2) New APTs like to remove libgtk1.2 to solve the problem, thus nuking
>      substantial amounts of gtk using packages in the process.
> dselect users (at least on top of APT) will not see this problem
>  *so long as they correctly select locales when prompted*!
> Jason

Seth Arnold | http://www.willamette.edu/~sarnold/
Hate spam? See http://maps.vix.com/rbl/ for help
Hi! I'm a .signature virus! Copy me into
your ~/.signature to help me spread!

Reply to: