[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: glibc 2.1 and compatibility (Was: slink is gone, goals for potato?

On Wed, Mar 03, 1999 at 09:24:25AM +0100, Stephane Bortzmeyer wrote:
> As far as I know (can a real guru confirm/deny?), there is no binary compatibility between glibc 2.0 and 2.1 (like it was between libc5 and glibc). So we'll have a difficult move, like between bo and hamm. And the packages which are compiled on potat will not run on slink or hamm.
> This is a serious problem for Debian :

I disagree.

> - it means that real users, who do not run 'apt-get dist-upgrade' every morning, will have the feeling to be abandoned (the bugs will be fixed only on potato and you will have to upgrade to get the bug fixes. Worse, the BTS has no provision for a bug fixed only in unstable, this is a real pain for stable releases users).

Lots of slink packages depend on libc6 >= 2.0.7u; hamm has 2.0.7t, so it's
not possible to install those packages on hamm. 

Let's be realistic; newer packages are going to need newer libraries.
It's not possible to ensure that any one package can be upgraded without
upgrading other parts of the system. I do not think it is unreasonable
to require some base packages to be kept up to date if the user wants
to keep other packages up to date.

In short: I do not think what you are asking is possible. The problems
you describe already exist.

> - it means that new packages (most of my biology packages were made after the slink freeze a long time ago) will not be available unless you install potato (which is far from stable).

This is already true; it's very likely that your packages cannot be installed
on a hamm system, for example (I have not checked the Packages file to be sure).

Hamish Moffatt VK3TYD              hamish@debian.org, hamish@rising.com.au
Latest Debian packages at ftp://ftp.rising.com.au/pub/hamish. PGP#EFA6B9D5
CCs of replies from mailing lists are welcome.   http://hamish.home.ml.org

Reply to: