[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Neat gtk/gdk-imlib pain

> > There is apparantly an EGCS patch called libapi, available in the
> > Debian egcs package, which is supposed to implement the above.
> > Adopting and improving this patch would definitely solve your GNOME
> > problems, Jim.
> Can you give us some pointers? This sounds like a good thing for the gnome
> people to adopt upstream as well..

It's in the egcs package.

# DP: Patch to include the c++ compiler interface, the libstdc++ version
# DP: and the libc version in the libstdc++ soname. (From H.J. Lu)

It's why the libstdc++ libs look like:


  SONAME      libstdc++-libc6.1-1.so.2

The only problem is, for libgnome, the library might end up looking


Gawd knows what I'd name the package as.

It's just a variation on the bumping the soname idea.

We'd still have the problem where we'd get a huge explosion in the
number of libraries hanging around.


 - Jim

Reply to: