[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: glibc recompiling was Re: libc resolver problem solved (critical bug)

   On Thu, Nov 19, 1998 at 10:36:26 -0500, Dale Scheetz wrote:
   > So, what is wrong with recompiling dpkg against the new library? The old
   > library is broken, so we have to move, and forward is the only logical
   > direction.

   There's nothing inherently wrong with it. But we have to be _very_ sure
   there's no upgrade scenario for users which will break dpkg and apt for them.

   The best way to do that perhaps is for you to build the new libc6 (including
   Conflicts: info for the affected dpkg and apt) and NMUs of dpkg and apt, and
   make sure they're installed in the same archive upgrade run.

The safe way to avoid troubles, IMHO, is to upload minor revisions of dpkg/apt
linked statically and ask peoples to upgrade. Then just say week before release
reupload shared version and we'll be fine...


Reply to: