[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Intent to fix base-passwd

Christian Meder <meder@isr.uni-stuttgart.de> writes:

> while testing the base packages I hit the critical bugs surrounding
> the update-passwd binary contained in base-passwd.

Uh, which critical bugs?  --sanity-check now works as expected, is run
by default and update-passwd is no longer run automatically, it has to
be run by the user if it is to be used.

> The postinst should be changed to something along the lines:
> update-passwd --sanity-check
> update-passwd -n
> Ask user if changes are ok.
> If yes
> update-passwd 

No, please don't do this.  Even if you do fix all the known bugs, it's
_way_ too late in the game to put an automatic call of update-passwd
back in the postinst.

~Yawn And Walk North~

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: