[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Egcs, gcc, and Debian -- Let's not forget C++

Laurent Bonnaud wrote:

> For C++ things are even more complicated.  The g++ version in egcs
> should use libg++2.8b6, so there is a problem with include files and
> dynamic libraries.  The next snapshot or release should include this
> new libg++.  Moreover there is a binary incompatibility caused by the
> inclusion of RTTI : you cannot link object files from the new compiler
> with an old libg++.so.  And there is exception handling, too (i did
> not
> try).  Because of the runtime cost of EH, it may be interesting to
> provide 2 versions of libg++.so.

I knew something like this would happen.  Bleah.

Anybody want to maintain libg++2.8b6?  Anybody want to come up with a
solution that lets it coexist with the old libg++?  I can't think of one
offhand. :-P


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: