[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#10516: gs-aladdin: Depends on svgalib1 (>= 1.210-1) which does not allow svgalib-dummy to fulfill the dependency



On Jun 12, joost witteveen wrote
> 
> Well, OK, I can see *somebody* wants this.
> But still I'm not convinced this warrants inclusion in stable.
> Are there other people that would like the dependancy change
> 
> - Depends: svgalib1 (>= 1:1.2.10-2)
> + Depends: svgalib1 (>= 1:1.2.10-2)|svgadummy
> 
> to go into stable?

Looks like a kludge to me. The proper fix is to make dpkg grok versioned
provides. Then svgadummy could "Provides: svgalib1 (= 1:1.2.10-2)" and
everyone can be happy.

  Christian

Attachment: pgp74nL7JvDnf.pgp
Description: PGP signature


Reply to: