[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#10516: gs-aladdin: Depends on svgalib1 (>= 1.210-1) which does not allow svgalib-dummy to fulfill the dependency

> On Jun 12, joost witteveen wrote
> > 
> > Well, OK, I can see *somebody* wants this.
> > But still I'm not convinced this warrants inclusion in stable.
> > Are there other people that would like the dependancy change
> > 
> > - Depends: svgalib1 (>= 1:1.2.10-2)
> > + Depends: svgalib1 (>= 1:1.2.10-2)|svgadummy
> > 
> > to go into stable?
> Looks like a kludge to me. The proper fix is to make dpkg grok versioned
> provides. Then svgadummy could "Provides: svgalib1 (= 1:1.2.10-2)" and
> everyone can be happy.

That's what I've been saying all along.

But Christoph thought the problem of not being able to install
gs on a "Webserver" (that does have X installed, but cannot for some
reason have svgalib installed, whatever that reason may be) was so
serious, that it had to be fixed NOW, in stable.

I just asked this list if there were other people that agree
with Christoph on this, but so far I haven't seen anybody respond.

joost witteveen, joostje@debian.org
#!/usr/bin/perl -sp0777i<X+d*lMLa^*lN%0]dsXx++lMlN/dsM0<j]dsj
$/=unpack('H*',$_);$_=`echo 16dio\U$k"SK$/SM$n\EsN0p[lN*1
#what's this? see http://www.dcs.ex.ac.uk/~aba/rsa/

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: