[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Adding conffiles to a package



On Jun 12, Kai Henningsen wrote
> phil@fifi.org (Philippe Troin)  wrote on 12.06.97 in <199706121732.KAA31530@tantale.fifi.org>:
> 
> > I'm stuck with the diald package, and I've got problems with users
> > from old versions. The thing is:
> > the files /etc/diald/diald.ip-{up,down} weren't conffiles, and now
> > they are.
> > Installing a new version of diald where the ip-up/down scripts are
> > conffiles on top of an old version where they weren't results in
> > overwriting of the files.
> 
> I'd like to call that a dpkg bug. When a file is a conffile in either the  
> new or the old package, dpkg ought to use conffile behaviour. Anything  
> else is just too dangerous.
> 

I don't know about the "conffile only in older package" situation,
but it seems like a good idea for the "conffile only in newer package"
situation.

  Christian

Attachment: pgpxmYriAtLPY.pgp
Description: PGP signature


Reply to: