[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Adding conffiles to a package

I'm stuck with the diald package, and I've got problems with users 
from old versions. The thing is:
the files /etc/diald/diald.ip-{up,down} weren't conffiles, and now 
they are.
Installing a new version of diald where the ip-up/down scripts are 
conffiles on top of an old version where they weren't results in 
overwriting of the files.

I was thinking of the following approach:
In the preinst, check for the version of the old package through the 
command line parameters, if the version we're upgrading from is too 
old, make backup copies of the files.
Then, in the postinst, offer to the user to either use his old 
conffiles, or the new ones which come with diald.

Will that work ???


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: