[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrading from 1.1 to frozen

Thomas Koenig wrote:
> I just spent an interesting afternoon trying to upgrade a 1.1 system
> to 1.3.
> First, /var/lib/dpkg/available was corrupted because of some
> incorrect values in the Version - field (somehow they had gotten to
> the format of 1:1-2 or similar; bug report submitted).  I fixed
> these by

This is a legitimate version format.  You failed to upgrade dpkg
before upgrading everything else.  Fellow Debian developers, we
_really_ need to put up warnings that this needs to be done!  Otherwise
innocent people will corrupt their systems by upgrading.  There shoud
be a heavily pointed-to "Upgrade FAQ", explaining that some packages
(dpkg, ldso, libc5) should be upgraded by hand before any attempt at
a massive "all at once" upgrade.

I think this would have prevented most of your other problems as


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: