[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrading from 1.1 to frozen

I just spent an interesting afternoon trying to upgrade a 1.1 system
to 1.3.

First, /var/lib/dpkg/available was corrupted because of some
incorrect values in the Version - field (somehow they had gotten to
the format of 1:1-2 or similar; bug report submitted).  I fixed
these by

Then, there were lots of dselect problems, since I wanted to upgrade
everything at once.  ldconfig was still running in the old version
(1.7.6), and libc wouldn't install because of this.  In between, Perl
got corrupted as well, so dpkg-ftp (which I used) didn't work either.
Somehow, my libc *.deb file got truncated to 0 bytes.  I ended up
by copying some key files (libc5-*.deb, perl-*.deb) to the tmp directory
via my non-Debian ssh (which still worked), then alternating between
installing everything and configuring everything.  After around
three or four interations, this worked.

Then, I rebooted to find that re-installing lilo had hosed my boot
configuration completely.  With this machine, I boot lilo from the
master boot record of /dev/hda.  My root partition resides on /dev/sdc2,
and boot files on /dev/sdc1.  After lots of fiddling around with the
rescue disks, I finally managed to create a working boot disk and
reboot into something remotely sane.

After that, there was nothing that I hadn't experienced before (e.g.
the X keyboard nationalization had suddenly stopped working - that bug
report has long since been filed).

If you have enemies, recommend that they should upgrade from Debian 1.1
to 1.3 this way.  They will hate you forever for it.
Thomas Koenig, Thomas.Koenig@ciw.uni-karlsruhe.de, ig25@dkauni2.bitnet.
The joy of engineering is to find a straight line on a double
logarithmic diagram.

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: