[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation test report: 1997-04-04

 I tested the installation disks today; the 1997-04-04 set from
the ftp://master.debian.org Incoming directory.

 Here's a list of things I found:

 When you boot the rescue disk, and press F9, the second line is too
long and the \n is at the edge, causing an extra blank line to be

 I also wonder, what will go on the other function keys???  Perhaps a
brief explaination of the order of the installation steps?  Or does
that belong in install.html?  Or things like how to scroll the linux
console with shift-pageup/pagedown, and that scrollock works?
Something about the log on f3 and f4?  The shell on f2? Or boot-line

 The 'Release Notes' dialog screen says that the disk was created on
Feb. 12, 1997.  That isn't right, is it?

 I've no CD, but do have a CDROM.  So after every dialog screen, there
was an error message that flashes by too fast to read.  I managed to
read it by re-invoking the keyboard setup a bunch of times: sda: dev
no ready... blah blah.  It is harmless, and won't happen if a CD is in
the drive, I suppose, but maybe we should warn about it in the
install.html file???  There may be people with CDROM's installing
another way who won't have a CD in there, and who may not understand
the error message.

 It occured to me that perhaps the reason that person's 3rd diskette
kept failing is that the disk got popped before the light went out?
Or that the dd commandline was wrong; no sync after it?  The docs
could mention that maybe.

 I also think there should be more explaination about the logs on tty3
and tty4.   We need to cater to the DOS-vet newbies.  I guess this is
something that the doc team is trying to address???

 After reboot, the starting message needs to be piped through the
pager.  I checked, and 'more' is there, so it could be used.  I knew
to press Shift-PageUp/PageDown to scroll the screen and read all of
the 'you need to set a root passwd' information, but a newbie won't.

 After you log in, it still says Debian 1.2 at login prompts.  I think 
the copyright date is saying 1996 also.  Some nice color ANSI would
look good too...

 The 'pon' script did not work.  I knew to edit, with 'ae',
/etc/ppp.chatscript and that 'pon' should start pppd.  A newbie won't
have a clue without documantation about this.  I think that the
netconfig with dialogs is excellent; why not extend it to fix up that
chatscript, through dialogs?  All it needs is the phoneNo, name, and
password.  And then the PPP/SLIP config.

 When I typed 'pon', it gave an error message from pppd.  Now that I
think about it again, maybe it would have run if I'd changed
/dev/modem in the /etc/ppp.options_out to /dev/ttyS1.  I guess the
dialog box config script will handle that?

 PPP worked fine when I typed the pppd commandline by hand.  I was
able to connect, and initiate an ftp method install.  (what's 6-8
hours out of my allotted 30-120 per month, if I'm getting an OS?  I
think modem installs are going to happen; especially when 56kbps gets
popular.  We should make that easy to do.)  A total newbie would not
know anything at all about this stuff; or that it even exists.

 Dselect's defaults for the ftp method resulted in an error:
Net::FTP: Bad Peer Address...line 405
... it worked fine after I entered the information at the prompts.  I
think all I changed was my email address... memory. grrr.

 I still like dselect better than RedHat's 'pretend its a GUI'
installer.  It is easier to view the package information.  It will be
good to have package sets and I hope that install order is fixed now.
TAB completion in the timezones config would be cool; but the ex-DOS
people won't know to use it anyhow, I guess.

 I noted also that shadow passwords are not installed by the base
system.  Wasn't that going to happen this time?

 I did not finish the installation by ftp'ing packages and installing
them; I only tested the install diskettes.  I will upgrade next week,
I think, :-) over the modem.

Karl M. Hegbloom <karlheg@inetarena.com>
Portland, OR  USA
Debian GNU 1.2  Linux 2.0.29t
You tell me and we'll both know.  I'm doing all I know how to do.

Reply to: