[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Experience with 5/21 boot/root/base disks



Yesterday I did a fresh install of Debian on a new disk,
using the 5/21 disks. The experience was generally good.

My system is a 16M 486, AMI Bios, Adaptec 1542c SCSI card, 1 SCSI
disk, and two IDE disks. I was doing the install onto the second
1.5G IDE. My (extensively upgraded but not particularly current)
0.93R6 system lives on the SCSI disk. For this test install,
I used a single big partition on the IDE disk, but used my
original swap on the SCSI disk.

Before I list the problems, I want to say that in general
it went very well, and I think it looks quite good. The actual
procedure is very straight forward, worked like a charm, and
the docs are good.

Now the problems :-(

1. (Not real problem, I'm listing it in case someone thinks it may
have some bearing on a later problem). When booting, it identified
my sound card (which I don't use under Linux) as a seeq8005 SCSI
adapter, whatever that is. I don't know if this is a general
problem under recent kernels because I build my own.

2. In the normal installation sequence, I was never prompted
for module configuration. I don't know if the intent was to
do so. If not, it should be mentioned in the install docs as
an option, since it's hiding out way down at the bottom of the
menu. Also, some description of why it might be useful would
be nice.

3. Module configuration doesn't work, at least the way I did it
(which could easily be wrong). I first went through the complete
installation in the suggested order, all the way to rebooting my
new system. I then rebooted from the install boot disk and root
disk, mounted the swap and root partitions (using the install
menus), and then tried the module configuration option. Two
sub-problems: the first screen says I can find out more information
by selecting individual items, but in most cases the info seems to
be missing. The real problem is that when I try to install a module,
I get error an error message about missing symbol information or
version problems (and I forgot to write the exact message down,
I'll run through it again later and post it). Also, the "net"
subsection didn't work at all: I would select "net", the 
screen would flash a couple of times, and I would be back
where I started. After messing around with this, I rebooted
again from the custom floppy.

4. ae (aka edit) is well and truly f****d. I started ae to add
my other disks to my fstab so I could get some stuff off them, and
the weirdness began. The function keys don't work, the arrow keys
don't work, and the text keys don't work. Normal typing doesn't
show anything until you hit return, and then it shows up *in reverse*.
That is, if I type "yes<CR>", what shows up on the screen is

<blank line>
sey

Very strange. The only way out of ae was to kill it from another
console. I tried this a couple of time from different virtual
consoles, and checked that TERM was set to "linux", and the tty
settings looked reasonable. BTW, ae (an older version) works just
fine on my .93R6 system, which is running a recent version of
ncurses (1.99).

5. Ok, so no editor until I install vi. I mount the my 0.93 partition
(where the .deb files are) under /mnt by hand. I cd to /mnt, and try

tar cvf /debian.tar ./debian

and it cranks away for a while, and then I get the message

ll_rw_block: device 08:01: only 512-char blocks implemented (4096)

and the tar hangs. I tried switching to another console, but
as soon as I tried to log in, I would get the same "ll_rw_block..."
message. Ctl-Alt-Del doesn't work. The reset switch does, and I'm
back to my old system. 

Summary: I think the only *real* problems are ae and possibly the
ll_rw_block: thing. I haven't blown away the new system, so if
somebody wants me to experiment or look something up, I can do
that.

(Oh, and I noticed that the base system has dpkg 1.2.0 on
it, I assume that will be brought up to date before release.)

Steve Greenland

-- 
The Mole - I think, therefore I scream 

			    "Splendid chaps.  Kill-crazy as all get out."


Reply to: