[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Analysis of "Nikki and the Robots" dependencies


On 11/14/2011 09:05 PM, Joachim Breitner wrote:
> sorry for not trying to reproduce it earlier, Paul. Yes, now I also
> observe this with the version that packaged earlier ( + 47
> patches in darcs).
> I tried to build the latest darcs version (, but it seems
> that it needs some dependencies upgraded:
> ../Base/Sound.hs:56:33:
>     Not in scope: type constructor or class `LoopedSound'
> ../Base/Sound.hs:59:10: Not in scope: `newLoopedSound'

Yes, sorry, it needs sfml-audio-3.something. It's already on hackage and
I've just updated the cabal-file in the repo.

> Anyways, back to If I change the keys and re-start the
> level, I can walk. I can even change keys back to the cursor keys, and
> it works.
> Starting the game, entering the level directly, it does not work.
> Changing the keys without stopping the level does not help. Then leaving
> the level and restarting does help.
> Now restarting the game, it works right away.
> Trying it a few times, always directly entering the tutorial, it
> sometimes happens and sometimes not. Seems to be a race condition of
> some kind. That’s all I can see for now.

Thanks. Still not sure what causes this...


(I am not subscribed, so please cc me!)

Reply to: