[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Analysis of "Nikki and the Robots" dependencies


Am Montag, den 14.11.2011, 18:42 +0100 schrieb Sönke Hahn:
> On 11/05/2011 06:54 AM, Paul Wise wrote:
> > On my desktop (nVidia GPU, nouveau driver) there is lots of display
> > glitches and I still get the no-movement bug.
> I'm a bit baffled by this. I cannot reproduce this. Just to clarify:
> When holding one of the arrow keys, Nikki turns around to face the
> correct direction but doesn't walk in that direction?
> Can you try to use other keys for moving around (configurable via the
> options menu)?
> (You can also display the slowdown of the game logic and the physics
> simulation by starting the game with -p. It should be around 0%. I'm
> pretty sure that's not the problem, though.)
> Once again: Hmpf.

sorry for not trying to reproduce it earlier, Paul. Yes, now I also
observe this with the version that packaged earlier ( + 47
patches in darcs).

I tried to build the latest darcs version (, but it seems
that it needs some dependencies upgraded:

    Not in scope: type constructor or class `LoopedSound'

../Base/Sound.hs:59:10: Not in scope: `newLoopedSound'

Anyways, back to If I change the keys and re-start the
level, I can walk. I can even change keys back to the cursor keys, and
it works.
Starting the game, entering the level directly, it does not work.
Changing the keys without stopping the level does not help. Then leaving
the level and restarting does help.
Now restarting the game, it works right away.
Trying it a few times, always directly entering the tutorial, it
sometimes happens and sometimes not. Seems to be a race condition of
some kind. That’s all I can see for now.


Joachim "nomeata" Breitner
Debian Developer
  nomeata@debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C
  JID: nomeata@joachim-breitner.de | http://people.debian.org/~nomeata

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: