[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on Azure - vmdepot

On Mon, Jan 14, 2013 at 01:56:06PM +0100, Arnaud Patard wrote:
> > Great, thanks! I'm downloading it while writing this. It's a bit
> > unfortunate that it's huge (10 Gb), so I suspect I'm downloading also
> > the "free space" on the disk, something that's avoided with other
> > formats, at least when the disk is still untouched.  If you've any tips
> > on how to avoid that, assuming it's feasible, please let us know.
> afaik, only vhd file format is supported, which means that one has to
> download the whole thing. There's a slightly different file format
> called vhd-x (x stands for extensible) but it's not supported.

So, a few more info on this, also after some IRC discussion with Arnaud.

- First of all, a (compressed) qcow2 disk image, equivalent to Wheezy
  VHD available on Azure is now available for download at:


  It's much easier to download and test, as it's "only" 514 MB.

- Exploring it it's not entirely easy though, here are some tips. It
  should be possible to mount it directly as qcow2 using NBD locally,
  but I didn't try that. I guess in theory it should also be possible to
  mount it as raw image (after conversion using qemu-img), but I didn't
  find the right combination of -o loop,offset=... to make it work. The
  difficulty here is that the VHD contains several partitions, so you
  need to be able to pinpoint the one you need to mount.

- What worked for me then is mounting directly the VHD, using vdfuse,
  which is shipped in Debian as part of the virtualbox-fuse package.
  Mini howto:

  1) convert qcow2 back to VHD (or download directly the VHD, but that's
     10 GB...) with something like:

     $ qemu-img convert -O vpc -f qcow2 \
         community-17-50526934-193e-480f-ac4c-35429a0dc2f2-1.qcow2 \

  2) mount the disk as a whole with something like:

     $ mkdir mnt-disk
     $ sudo vdfuse -t VHD -f community-17-50526934-193e-480f-ac4c-35429a0dc2f2-1.vhd ./mnt-disk/

     (you'll either need sudo, or uncomment "#user_allow_other" in
     /etc/fuse.conf for this to work)

  3) loopback mount the root partition available via fuse

     $ mkdir mnt
     $ sudo mount mnt-disk/Partition1 ./mnt/

  4) profit:

     $ ls mnt/
       bin  boot  dev  etc  home  initrd.img  lib  lib64  lost+found  media
       mnt  opt  proc  root  run  sbin  selinux  srv  sys  tmp  usr  var

I'd appreciate review of these steps, as well as suggestions on simpler
ways to inspect the content of Azure images, having available only
legacy Debian packages.

Also, volunteers are welcome for turning the above into a mini-howto for
our Azure page on wiki.d.o (hint hint!).

> > Thanks for the pointer! Is anyone here interested in packaging it? I'm
> > personally not, but I think we should strive to package the stuff we use
> > to build Debian. So if noone is interested at present, I think we should
> > at least file an RFP to avoid forgetting about this.
> fwiw, it requires node-js 0.8.16. node-js devs are working on 0.8.11 for
> experimental [1] but it won't work. Also, a lot of dependencies are
> probably lacking.

OK. Still, I think we should keep this in mind. Any objection into
filing an RFP? Any volunteer to do so, also making sure that it will
show up at bugs.debian.org/cloud.debian.org ?

> > I'd still like to hear back from people who have worked on the Azure VM
> > about the "Debian Wheezy" naming. It's a pretty important issue, even
> > though it is so only for the time being.
> It's quite easy to change the image name so as long as there's an
> agreement on the name to use, it can be changed in few mins/hours.

Well, I'm happy to take responsibility for that then :-). The image
should not be titled "Debian Wheezy" until Wheezy is released. Please
rename it to "Debian testing" and mention "Wheezy" in the longer
description, together with the date (and time, as Wheezy can chance up
to 4 times a day).

Stefano Zacchiroli  . . . . . . .  zack@upsilon.cc . . . . o . . . o . o
Maître de conférences . . . . . http://upsilon.cc/zack . . . o . . . o o
Debian Project Leader . . . . . . @zack on identi.ca . . o o o . . . o .
« the first rule of tautology club is the first rule of tautology club »

Attachment: signature.asc
Description: Digital signature

Reply to: