[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#686471: marked as done (cdimage.debian.org: Please made DVD-1 image small enough to fit on a 4GB USB stick)

Your message dated Thu, 13 Sep 2012 16:10:57 +0100
with message-id <20120913151057.GC29044@einval.com>
and subject line Re: testing report [Re: Bug#686471: cdimage.debian.org: Please made DVD-1 image small enough to fit on a 4GB USB stick]
has caused the Debian Bug report #686471,
regarding cdimage.debian.org: Please made DVD-1 image small enough to fit on a 4GB USB stick
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

686471: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686471
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: cdimage.debian.org
Severity: wishlist
Tags: d-i

It would be nice if the DVD-1 iso image were just a bit smaller, so it would fit
onto a 4 GB USB flash drive.

I'm presonally interested in seeing this happen for PowerPC architecture,
but I'd even be happy if it only happened for the x86/amd64 architecure
if that's the best we can do in the Wheezy timeframe.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: powerpc (ppc)

Kernel: Linux 3.2.0-3-powerpc
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
On Thu, Sep 06, 2012 at 11:36:31PM -0700, Rick Thomas wrote:
>Well, it wasn't Tuesday. More like Thursday, but I did manage to get
>to it today.  Here's my report...
>I downloaded both the amd64 and powerpc weekly DVD-1 iso's from
>9/3/2012 and copied each to a 4 GB USB flash thumb-drive, using "dd".
>Each booted as expected and ran the install process thru
>partitioning, telling it *not* to use a mirror (wanting to make sure
>the smaller DVD-1 installer wasn't missing anything important), then,
>finally, running task selection and finishing the installation.  I
>installed a standard desktop environment: gnome on the powerpc, and
>xfce on the amd64.
>When it came time to write the boot-loader, they both showed symptoms
>of bug #684265 -- not able to find existing OS's and make entries for
>them in the bootloader config file.
>Fortunately, the amd64 grub boot loader creation script did some
>self-checking, and noticed that there was only one OS in the setup it
>was about to write.  It asked me if I wanted to write a MBR that I'd
>only have to re-do later to pick up the other OS's (if any).  I
>decided to see if there were other options and answered "no".  It
>then asked if I wanted to write the boot block to the partition I was
>installing to.  I said "yes" but that failed for some reason (I don't
>remember the error message, and I don't think it was helpful even if
>I could remember.)  So then I tried using lilo to a second USB stick.
>That worked and booted fine.  If I booted without the USB stick, it
>booted to the previous default OS.  "Cool!" that there's a
>workaround, but "Uncool!" that it's so roundabout!  I'll be happy to
>supply the syslog file if you want to take a look.
>The powerpc yaboot boot loader creation script isn't so intelligent.
>It didn't check, and therefor didn't recognize there was a problem,
>so it went blithely ahead and created a one-entry yaboot
>configuration, which I had to repair manually after rebooting.  Once
>again, I have the syslog file from this installation and I'll be
>happy to supply it if you want to take a look.
>If you can point me at which package I should post a wishlist bug to,
>I'd love to have the yaboot bootloader creation script be as smart as
>the one for grub about "Hey! There's only one OS here."
>With the above-described workarounds, all went well with the post-
>installation reboots.  The respective desktop environments seem
>complete and fully-functional.

Cool, thanks for checking that. I'm closing #686471 now. :-)

>PS:  Is anybody working on bug #684265?  It would be a shame if it
>got into beta2...

Yes, it would...

Steve McIntyre, Cambridge, UK.                                steve@einval.com
"Since phone messaging became popular, the young generation has lost the
 ability to read or write anything that is longer than one hundred and sixty
 characters."  -- Ignatios Souvatzis

--- End Message ---

Reply to: