[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#686471: testing report [Re: Bug#686471: cdimage.debian.org: Please made DVD-1 image small enough to fit on a 4GB USB stick]

On Sep 2, 2012, at 4:11 PM, Rick Thomas wrote:

On Sep 2, 2012, at 3:39 PM, Steve McIntyre wrote:

tags 686471 pending

On Sun, Sep 02, 2012 at 02:37:08PM -0700, Rick Thomas wrote:

On Sep 2, 2012, at 1:31 AM, Steve McIntyre wrote:

I've not done anything like isohybrid for ppc at all; I've no idea if
it's even possible...

It may not be strictly necessary.  See my recent email with subject
"Detailed notes: How to boot and install Debian from a USB stick on a PowerPC Mac" that I sent to the debian-powerpc list. I have used the "businesscard", "netinst", "CD-1" and "DVD-1" iso's successfully with
that procedure to install Debian wheezy on PowerPC Macintoshes from
USB sticks.  For the DVD-1 I needed an 8GB stick, of course.

Ah, OK. Lovely. :-)

I'll tweak sizes now for you... Done. Tomorrow's weekly build will get
a 4GB DVD#1, and the same should filter through to wheezy d-i beta
2. Please confirm if it works ok for you!

4GB sticks are now selling for US$3.00 a piece.

Oh, yes. :-)

Thanks!  I'll give it a try on Tuesday if I can.  Enjoy!


Hi Steve!

Well, it wasn't Tuesday. More like Thursday, but I did manage to get to it today. Here's my report...

I downloaded both the amd64 and powerpc weekly DVD-1 iso's from 9/3/2012 and copied each to a 4 GB USB flash thumb-drive, using "dd". Each booted as expected and ran the install process thru partitioning, telling it *not* to use a mirror (wanting to make sure the smaller DVD-1 installer wasn't missing anything important), then, finally, running task selection and finishing the installation. I installed a standard desktop environment: gnome on the powerpc, and xfce on the amd64.

When it came time to write the boot-loader, they both showed symptoms of bug #684265 -- not able to find existing OS's and make entries for them in the bootloader config file.

Fortunately, the amd64 grub boot loader creation script did some self- checking, and noticed that there was only one OS in the setup it was about to write. It asked me if I wanted to write a MBR that I'd only have to re-do later to pick up the other OS's (if any). I decided to see if there were other options and answered "no". It then asked if I wanted to write the boot block to the partition I was installing to. I said "yes" but that failed for some reason (I don't remember the error message, and I don't think it was helpful even if I could remember.) So then I tried using lilo to a second USB stick. That worked and booted fine. If I booted without the USB stick, it booted to the previous default OS. "Cool!" that there's a workaround, but "Uncool!" that it's so roundabout! I'll be happy to supply the syslog file if you want to take a look.

The powerpc yaboot boot loader creation script isn't so intelligent. It didn't check, and therefor didn't recognize there was a problem, so it went blithely ahead and created a one-entry yaboot configuration, which I had to repair manually after rebooting. Once again, I have the syslog file from this installation and I'll be happy to supply it if you want to take a look.

If you can point me at which package I should post a wishlist bug to, I'd love to have the yaboot bootloader creation script be as smart as the one for grub about "Hey! There's only one OS here."

With the above-described workarounds, all went well with the post- installation reboots. The respective desktop environments seem complete and fully-functional.



PS: Is anybody working on bug #684265? It would be a shame if it got into beta2...

Reply to: