[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: experiences with debian amd64 EFI test CD, build 3

Hi Steve,

ok, I was partly able to reproduce my last setup. The good news is, it was really partly my fault. Back to what happened: my original system (win/debian) runs on a 500GB HD. At the very beginning, I installed Win7 as UEFI and debian as MBR since I was not aware that I even have an UEFI board (... :-)). Before I thought about reinstalling Debian (and before I discovered the EFI CDs) I tried to fix that by running a lot of commands ( I really don't know anymore which ), that created a grubx64.efi on the existing EFI boot partition. That did not help (grub would not show up) so I reinstalled Debian using the EFI CDs and ... got the error "no EFI boot partition found". Since that PC is not mine, I fear to reinstall Debian there for the moment. But I guess all those commands I tried to get grub running at first, could have caused that error later (since I changed some files on the original EFI boot partition)

That is why I tried to install the same setup on a spare 2TB HD. As I mentioned, this does not work since the Debian installer stops working after I choose an option like "text mode installer", "graphical mode installer", "text mode rescue". No matter which option I choose, the CD stops spinning and nothing happens. I cannot even pull a log at this moment, so I fear I cannot provide more debug information here (or is there another way?) Is there hope that the installer will work with 2TB HDs soon?

So I tried with a spare 250GB HD: fresh Win, fresh Debian. The installer is able to detect the Win EFI boot partition and installs grub into that partition. However grub will not detect the Win OS. I still have to create that grub script to add the Win entry to the grub menu. I guess this is a grub problem rather than a problem of that installer?

Sooo I guess the only way to reproduce that error is to go back to the original PC and ask if I can reinstall Debian there. However I am not sure that is of help since I guess (or hope) that most of the people won't start messing around with the EFI boot partition and try install a proper system afterwards :) ?


On 09/03/2012 12:10 PM, Steve McIntyre wrote:
On Mon, Sep 03, 2012 at 11:51:14AM +0200, Carolin Latze wrote:
OK, thanks for that. Hmmm, not quite sure why it's not using the
existing partition here. Do you have anything important on the Debian
system yet? Could you try a reinstall and grab the syslog off for me
Yes, ok, I can do that. I will use another HD, and reinstall the same
setup there. By doing that I can also be sure that error did not come up
due to a mistake I made :-)

What do you want me to do in detail? Use the EFI installer, don't create
an EFI boot partition and if the error shows up, create one, finish
installation and send the syslog to you?
Ish. Please run the installation again, at least up until the point
where it recognises (or not) the Windows EFI boot partition. If you
can send logs at that point, that would be great. You'll probably need
to copy them off onto the hard drive somewhere else, or onto a USB
stick. I'm hoping there will be a clue in the logfile, then I'll
probably give you replacements for a couple of the installer packages
or a new image with more debug in the right area. OK?

Thanks for helping with this, it's invaluable.

Reply to: