[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CDs won't boot, give a failed crc, or don't give a menu

Michael Loftis wrote:

> --On December 2, 2005 12:02:22 AM -0800 David Liontooth
> <liontooth@cogweb.net> wrote:
>> OK, I tried that -- wget
>> http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386
>> -netinst.iso
>> Fails. Boots to the welcome screen, I press return, reads the compressed
>> image, and gives a crc error. On two very different machines. That's my
>> sixth coaster.
>> Debian doesn't seem to have a working boot CD anywhere.  I guess I'll do
>> a debootstrap.
> Check your md5sum of that image against the available MD5SUMS file
> before burning.  If they do match, then it's a burner or burner media
> compatibility problem you're experiencing.  I know for a fact that
> netinst image works, we just installed a machine yesterday with it. 
> If they don't match, make sure you're getting the whole file. 
> Whenever you're not using a download manager like jigdo, getright, or
> something similar, theres the chance that the browser or utility
> thinks it received the whole file but was really just disconnected due
> to a network event.
> Either way, you're having some non-debian local issues here :(  Sorry.

Right, as I discovered and wrote a while back, one of my burners messes
up the image for some reason.  Still, even when I got the sarge image
booting, I ran into problems with base-install that don't seem to have a
known solution (see earlier mail). In the end I used the old LordSutch
potato CD with a 2.2 kernel, worked well enough -- and then updated
straight to a 2.6 (built on a sister machine) and sid. Some difficulties
on various fronts, but in the end a clean install -- and tiny, only
300MB. This is an older machine (Dell optiplex glx), but the latest
kernels run fine on them.

Before I reinstalled, I had been running various 2.4 kernels on this
machine for a couple of years, without touching it -- so I don't feel
that bad about spending some time on it. Still, I'll think twice before
I use a CD to install Debian again; I could have done a debootstrap or
just a raw copy in a fraction of the time.

In sum, the installation took twelve hours solid. 


Reply to: