[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new ZFS installs completely broken in Wheezy/Sid

2011/12/12 Steven Chamberlain <steven@pyro.eu.org>:
> Looks like zfsutils 8.3 still has Breaks in place for 8.1/8.2 kernels,
> since 8.3~svn226546-3, so I guess it is safe to migrate to testing, and
> bug #648744 is unnecessary?

This would force all ZFS users of kfreebsd 8.2 in Wheezy to upgrade to
9.0.  I think we should wait for the release before doing this.  OTOH
if new installs are broken, that's a big problem too.

> zfsutils-udeb doesn't use Breaks, because the 8.2 and 9.0 images are
> must both be present, so...

Yes. A runtime check is needed.

> I just tried another install using partman-zfs 16 and kfreebsd-8, which
> allows zpool/volumes (v15) to be created with zfsutils 8.3 and it
> generates a zpool.cache, but partman is still not listing any volumes as
> mentioned before.
> If that issue could be fixed somehow, [...]

Maybe it can, but the ABI incompatibility is probably a much deeper
problem than just ZVOL support.  E.g. I wouldn't be surprised if
"zpool status" reports wrong data.

Robert Millan

Reply to: