[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new ZFS installs completely broken in Wheezy/Sid


On 11/12/11 17:38, Robert Millan wrote:
> 2011/12/11 Arno Töll <debian@toell.net>:
>> Back then I assumed that was quite intentional as upgrading to a 8.3
>> kernel solved the problem. That's why we added breaks conditions to the
>> package back then. Aside of this problem there didn't seem to be a hard
>> (i.e. API or ABI) incompatibility which would have caused a crash or so.
> TTOMK all break conditions are in place, but these don't cover all
> possible combinations presented by D-I.

Looks like zfsutils 8.3 still has Breaks in place for 8.1/8.2 kernels,
since 8.3~svn226546-3, so I guess it is safe to migrate to testing, and
bug #648744 is unnecessary?

zfsutils-udeb doesn't use Breaks, because the 8.2 and 9.0 images are
must both be present, so...

> The isinstallable script at least ought to be working.  Any idea
> what's wrong with that?

> zfsutils is not a required module, it's supposed to be optional (just
> like partman-zfs).

partman-zfs and zfsutils 8.3 both get installed without a choice,
instead of being listed in the menu of optional installer modules.  I
don't know why.  It sounds like the .isinstallable feature is only
supposed to hide items from that menu?

I just tried another install using partman-zfs 16 and kfreebsd-8, which
allows zpool/volumes (v15) to be created with zfsutils 8.3 and it
generates a zpool.cache, but partman is still not listing any volumes as
mentioned before.

If that issue could be fixed somehow, maybe it would be unnecessary to
try to include zfstils-udeb 8.2 in the installer?

Steven Chamberlain

Reply to: