[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hmm...

> One misunderstanding that I have read, is that many Debian users believe
> that the BSD ports/packages systems are week or don't work very well --

The particular case that pkgsrc falls down on is upgrading a
compatible library.  In debian, if libpng2 gets a fix, a new rev of
libpng2 goes in "in place".  In pkgsrc, the only way to replace
libpng2 would be to uninstall everything that depends on it, then
replace it, then reinstall everything on top.  Arguably correct in an
impractical sort of way...

(likewise if a libpng3 appears, it goes in also, and nothing needs
upgrading until new versions of apps that use libpng3 exist.)

If this *is* a misunderstanding, please demonstrate...

Reply to: