[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#848304: Installation report for Stretch on cubietruck (armhf)

Package: installation-reports

Boot method: Debian installer on sd card, using Cubietruck firmware + partition.img
Image version: http://ftp.uk.debian.org/debian/dists/stretch/main/installer-armhf/current/images/netboot/SD-card-images/
Date: 2016-12-15 7:00 PM Pacific standard time

Machine: Cubietruck (Allwinner)
Processor: ARMv7 Processor rev 4 (v7l)
Memory: 2061944 kB
Partitions: Installation didn't complete this step

Output of lspci -knn (or lspci -nn): None (shelled out from installer and this produced no output)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [ O ]
Detect network card:    [ O ]
Configure network:      [ O ]
Detect CD:              [ ]
Load installer modules: [ E ]
Detect hard drives:     [ O ]
Partition hard drives:  [ E ]
Install base system:    [ ]
Clock/timezone setup:   [ O ]
User/password setup:    [ O ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ E ]


Installing Stretch using current (dated 31 Oct 2016) firmware and net installer does not complete. The following error is encountered during the install: 

"No kernel modules were found. This probably is due to a mismatch between the kernel used by this version of the installer and the kernel version available in the archive. If you're installing from a mirror, you can work around this problem by choosing to install a different version of Debian. The install will probably fail to work if you continue without kernel modules. Continue the install without loading kernel modules?"

Selecting "Yes" causes the installation to fail at the disk partitioning step, apparently due to the lack of an appropriate kernel module. I have the three files made available for debugging by the installer: hardware-summary.txt, syslog.txt, and partman.txt and can share them upon request.

Under the theory that waiting a while might allow the repository and the kernel to sync, I attempted the installation multiple times over the course of several weeks and never got a different result, hence this installation report. I also tried prior versions of the installer as well as the stable version (Jessie) and none that I tried completed successfully.

In the past I have successfully installed Debian on the Cubietruck using the sd card method, as well as other ARM devices; so I am experienced in this installation process.

Reply to: