[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#848304: Installation report for Stretch on cubietruck (armhf)

On Thu, Dec 15, 2016 at 07:44:23PM -0800, John Kerenyi wrote:

> Package: installation-reports
> Boot method: Debian installer on sd card, using Cubietruck firmware + partition.img
> Image version: http://ftp.uk.debian.org/debian/dists/stretch/main/installer-armhf/current/images/netboot/SD-card-images/
> Date: 2016-12-15 7:00 PM Pacific standard time
> Machine: Cubietruck (Allwinner)
> Processor: ARMv7 Processor rev 4 (v7l)
> Memory: 2061944 kB
> Partitions: Installation didn't complete this step
> Output of lspci -knn (or lspci -nn): None (shelled out from installer and this produced no output)
> Base System Installation Checklist:
> [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
> Initial boot:           [ O ]
> Detect network card:    [ O ]
> Configure network:      [ O ]
> Detect CD:              [ ]
> Load installer modules: [ E ]
> Detect hard drives:     [ O ]
> Partition hard drives:  [ E ]
> Install base system:    [ ]
> Clock/timezone setup:   [ O ]
> User/password setup:    [ O ]
> Install tasks:          [ ]
> Install boot loader:    [ ]
> Overall install:        [ E ]
> Comments/Problems:
> Installing Stretch using current (dated 31 Oct 2016) firmware
> and net installer does not complete.  The following error is
> encountered during the install:
> "No kernel modules were found. This probably is due to a
> mismatch between the kernel used by this version of the
> installer and the kernel version available in the archive. If
> you're installing from a mirror, you can work around this
> problem by choosing to install a different version of Debian. 
> The install will probably fail to work if you continue without
> kernel modules.  Continue the install without loading kernel
> modules?"
> Selecting "Yes" causes the installation to fail at the disk
> partitioning step, apparently due to the lack of an appropriate
> kernel module.  I have the three files made available for
> debugging by the installer: hardware-summary.txt, syslog.txt,
> and partman.txt and can share them upon request.
> Under the theory that waiting a while might allow the
> repository and the kernel to sync, I attempted the installation
> multiple times over the course of several weeks and never got a
> different result, hence this installation report.  I also tried
> prior versions of the installer as well as the stable version
> (Jessie) and none that I tried completed successfully.


I have today tried to reproduce the issue with the current
Stretch installer image


and with that everything works for me without problems. We had a
kernel migration from unstable to testing on 2016-12-16, so this
might explain why the image from 2016-12-15 didn't work properly
for you, while the one from 2016-12-18 did for me.  Could you
perhaps re-try the installation with the image pointed to above?

What I don't understand is why the Jessie installer doesn't work
for you as well.  We haven't had a kernel ABI change in stable
since ages and to be sure that no other problem has crept up,
I have just run a full Jessie install on a Cubietruck with the
image from


This has also worked without any problems, so I have no indication
what might cause the failure in your case.

Can you provide the installer log from a case where the installer
fails for you?  One possible source of problems could also be a
broken/stale mirror, so choosing a different mirror during
the installation could be worth a try.

Gem. Par. 28 Abs. 4 Bundesdatenschutzgesetz widerspreche ich der Nutzung
sowie der Weitergabe meiner personenbezogenen Daten für Zwecke der
Werbung sowie der Markt- oder Meinungsforschung.

Reply to: