[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Boot problem in squeeze, hang after Booting the kernel

 Part of the problem found !

 I can now get console ouptup from 2.6.32 in the same way as 2.6.30-8
... the thing is that I found some bad RAM.

 However the last thing I see is unpacking initrd something ....

 After that it dies in the kernel, ( I have the debug flag on ) ... it
ends up in the kernel_init something ... ( threads ? )

 I have checked the initrd image and it actually looks fine...

 So , it's probably NOT a bug with the debian kernels !

 Any suggestions on how to proceed appreciated ...

2010/2/15 Lars Segerlund <lars.segerlund@gmail.com>:
>  I tried the 2.6.30 kernel you suggested, now it tries to boot, but I
> get a kernel panik after trying to mount the root. I cannot make out
> too much but I have console output which I do not have with the
> regular 2.6.32 kernel.
>  I suspect they hang at the same place though, with the difference of
> the output o the screen, ( only if using the debug flag ) ...
>  I get some messages about popullating the foot fs, and vfs, after
> that whe I get to kernel init its game over. I cannot scroll backwards
> with shift-pageup ... in order to see what happens when it fail, and
> if I could get some output I could try to diagnose.
>  Any ide´a on how to proceed ?
>  The biggest problem seems to be that it panics when mounting the root
> fs. But if I could get console output from the 2.6.32 kernel I would
> know a bit more, I know the i945g graphics chip can be a bit picky
> ....
>  Any ideas ? Should I open a bug report ?
>  / regards, Lars Segerlund.
> 2010/2/14 Frans Pop <elendil@planet.nl>:
>> On Friday 12 February 2010, Lars Segerlund wrote:
>>>  I have a Sony Vaio TX3 ( VGN-TX3XT ) , which runs a on an intel
>>> celeron ULW, and has a i945g graphics chip.
>>>  I have reinstalled with the squeeze install cd, but cannot boot the
>>> kernels on the machine.
>> So the installer boots and works correctly, but the installed system fails
>> to boot. As the installer uses a 2.6.30 kernel and the installed system
>> gets a 2.6.32 kernel, it sounds like a kernel regression that affects your
>> system.
>>>  I can get into the machine from the rescue mode on the installer, (
>>> if I chroot into the env. it looks fairly ok ).
>> Try installing a 2.6.30 linux-image package. You can find one here:
>> http://stabile.debian.org:5001/package/linux-2.6/2.6.30-8/
>> If that works, then please file a BR against the linux-2.6 package.
>> You may also want to try if 2.6.31 works or not. You can find packages for
>> that if you move up one directory level in the URL above.
>> You should also try the very latest 2.6.32 packages from unstable to see if
>> the problem has already been fixed there.
>>>  I have tried noapic nolapic acpi=off no-hlt no-irq nomodeset and most
>>> options I can find to the kernel.
>>> I suspect it hangs partly into the linux init() function, and if i
>>> set vga=788 or vga=777 the text clears and I am greeted with a blank
>>> screen ... ( vga=788 is what the installer cd uses ).
>> Make sure you also remove the 'quiet' option so you get all the boot
>> messages on your console. That may give a better idea where the boot is
>> failing.
>> Cheers,
>> FJP

Reply to: