[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Boot problem in squeeze, hang after Booting the kernel


 I have a Sony Vaio TX3 ( VGN-TX3XT ) , which runs a on an intel
celeron ULW, and has a i945g graphics chip.

 I have reinstalled with the squeeze install cd, but cannot boot the
kernels on the machine.

 I can get into the machine from the rescue mode on the installer, (
if I chroot into the env. it looks fairly ok ).

 I can boot memtest86 and memtest86+ from the boot menu on the hd, but
not the kernels.

 I have looked at the initrd and it looks ok, ( atleast it is possible
to gunzip, and un cpio it and have a look around ).

 grub2 reads the initrd image, unpacks the kernel and hans after
writing 'Booting the kernel'

 I have tried noapic nolapic acpi=off no-hlt no-irq nomodeset and most
options I can find to the kernel.
 I suspect it hangs partly into the linux init() function, and if i
set vga=788 or vga=777 the text clears and I am greeted with a blank
screen ... ( vga=788 is what the installer cd uses ).

 I have tried linux-image-2.6.32-trunk-686,
linux-image-2.6.32-trunk-486 , linux-image-2.6.30-trunk-686 to no

 I suspect I am loosing the display so that I don't get the kernel
output, and I don't have a serial port on it.

 I simply does not know howto continue debugging this, does anyone
have any idea?

 Any help apreciated.

 Next I will build the kernel from source on the system, and try.

 / regards, Lars Segerlund.

Reply to: