[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: FYI: current issues

Hi Aníbal,

I sent you this over a week ago, but never received a reply. Did you get the 
mail? Think you can fix it yourself or could you use some help?


On Thursday 17 April 2008, Frans Pop wrote:
> On Thursday 17 April 2008, Aníbal Monsalve Salazar wrote:
> > There is a new shared library. Version 1:2.2.10-1 didn't ship a
> > shared library.
> Thanks for that. It's simple to see that the udeb is currently broken.
> $ dpkg -I pciutils-udeb_3.0.0-1_i386.udeb | grep ^Depends:
>  Depends: libc6 (>= 2.7-1), libpci3
>                             ^^^^^^^
> This means that the udeb currently depends on the regular library, which
> is not good. As no other packages need libpci, I think our preference is
> that the library is packaged in the same udeb as the executable, or that
> it is compiled in statically for the udeb.
> If the library is included inside the existing udeb, then please make
> sure that there is no unneeded dependency or self-dependency.
> If there are other udebs that could usefully use a separate libpci, then
> the situation would be different.
> Please do not upload to unstable until this is fixed and a new version
> has been tested.
> Cheers,

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: