[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#420809: marked as done (Bug: Installation-reports: init placed in /sbin/init but Grub looks for it as /init)

Your message dated Wed, 09 May 2007 00:09:46 +0200
with message-id <0JHQ000HKTKANJ@smtp18.wxs.nl>
and subject line Bug#420809: Installation-reports: init placed in /sbin/init but Grub looks for it as /init
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: Installation-reports
Version: debian-40r0-i386-CD-1.iso
Severity: Important

(NB: originally rejected because Package: was not first, but I copied from your example in which Package: was also not first)

Performed a mostly default install of the current stable as of yesterday on a PIII with a single HD, which I specified should all be used and should be reformatted. On initial reboot got a kernel panic: "can't find /init". As Grub does not (apparently) provide any means of browsing the HD, and I could not get find to find init, I had to guess. Finally adding init=/sbin/init to the kernel line worked.

Since no configuration option is presented as to where init should be placed, I do think Grub and the installer should agree a priori.

makes the release not suitable for naive users.

David Warman

--- End Message ---
--- Begin Message ---
> Suggesting that the real problem was with grub being able to reliably load
> the initramfs from disk, and that some other change you made to the disk
> config corrected this problem.

Although the cause is still not really clear, I'm closing the report as the
problem was resolved. We have not received any other reports of a similar
issue, although it could be the known issue with device ordering that is
listed in the errata for Etch.


--- End Message ---

Reply to: