[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#413814: installing Debian GNU/Linux 4.0 on a Power Macintosh G3 Server

Hi Alex!

Welcome to an elite minority of those of us who have got this to work!

Below are a couple of hints from my own experience in doing this.


On Mar 7, 2007, at 5:21 AM, Alex Teclo wrote:

Package: installation-reports

Boot method: BootX
Image version: Debian etch powerpc weekly build
Date: February 4th 2007

Machine: Power Macintosh G3 Server
Architecture: powerpc
Processor: PowerPC 740/750 (G3)
Memory: 256 MB

Here's a feedback of my installation of Debian 4.0 "etch" on a Power Macintosh G3 MiniTower

Since it's an oldworld macintosh, it cannot boot from the Debian CDs. I tried booting from floppies, but it never worked, the floppy drive is probably dead.
So my solution was to install a legit copy of MacOS 9.2

Here's what I did:
- boot into MacOS 9.2
- launch BootX with the files vmlinux and initrd.gz
- debian-installer runs smoothly and everything goes well, except one thing: when debian-installer attempts to install quik as a boot loader, the operation fails, and the error messages states that "the partition is not ext2". This error messages seems odd to me. What partition does d-i mean ? The partition where MacOS 9.2 is, which is HFS ? One of the Linux partitions, which are ext3 and not ext2 ? Anyway, isn't ext2 the same thing as ext3 without journalization ? - anyway I'm not worried at all that quik could not install, because I still can boot into MacOS 9.2 and then fire up BootX to boot into Debian GNU/Linux
- debian-installer finished up its work and reboots the machine
... and then something goes wrong: I see on the power macintosh a flashing "?" in a floppy. This means "I can't find any operating system to boot" ... ouch ! Now that's a problem.
- I tried zapping the PRAM, it did not help.
- Finally I took the "Outil Disque Dur" diskette and chose the menu "Fonction" and then "Mise à jour". Pardon my French, this should translate to "Apple Disk Tool", menu "Functions" and then "Update". I don't know the exact wording since I've never used MacOS 9.2 in any other language than French :)
... and *yes*, now I can boot into MacOS 9.2

At some point after the installer has stepped you through choosing language and keyboard, but before running the partitioner, you can choose "go back" from one of the question screens. That will get you to a top-level menu which has an option (near the bottom) of changing the priority level of the questions that the installation asks you. Change it to "low" or "medium". From now on, the installer will return to that top level menu screen between installation steps. It will also ask you more questions than it did at default priority -- just choose the defaults if you don't know the answers.

This will give you a chance to prevent it from trying to install the quik bootloader (choose "proceed without installing a boot loader" instead.) This will keep it from messing up the OS-9 bootstrap stuff.

When it ejects the CD and pauses one last time before rebooting, switch to VT2 (hit <alt>-F2) where you can start up a limited shell by hitting the <return> key. The root partition for the installation is mounted on "/target". have a look around if you like (do "ls", "df", "ps" and anything else non-destructive.) Then do the following stuff:

	mkdir /target/MacOS
# you *may* need to do "modprobe hfs" here (or "modprobe hfsplus"). I don't recall. # In any case, you've got the installer kernel and it's associated modules in the
# installer ramdisk, where you currently are, so it will work.
mount -t hfsplus /dev/hda6 /target/MacOS # or "-t hfs" if that's what it is.
	chroot /target
# Now you're in "bash" inside the installed system.
# If you like, you can poke around a bit now to get a feel for the environment. cp /boot/vmlinux /MacOS/System\ Folder/Linux\ Kernels/vmlinux-new # or whatever you like to call it cp /boot/initrd.img /MacOS/System\ Folder/Linux\ Kernels/initrd- new.img # or whatever
# now you're back into the installer environment with it's limited shell
	umount /target/MacOS

Then switch back to the VT1 (<alt>-F1) console and proceed with the final stages of the installation.

It will reboot into MacOS-9.2 and pause at the BootX screen. Enter your "root=/dev/hda9" in the parameter box and choose your new kernel and initrd.img files. Then allow it to boot into Linux. You should be good to go.

... but now when I boot into Debian GNU/Linux with BootX, there is another, more serious problem: When I boot into Debian GNU/Linux with BootX, I can only use the vmlinux and initrd.gz of debian-installer. So instead of booting into my system, I boot into debian-installer. Attempt to solve this problem: start a shell from debian-installer, and chroot to my Debian GNU/Linux system. From there, find the vmlinux and initrd.gz that will allow me to boot directly into Debian GNU/Linux (they are in /boot) and make them accessible to the MacOS 9.2 system. But... First attempt: mount the MacOS 9.2 (HFS) partition in read/write and copy vmlinux and initrd.gz there. The hfs driver isn't built in the kernel, so I need to load it with modprobe hfs... But alas ! It fails because it's not the same kernel version ! Indeed, I'm running the vmlinux kernel from debian-installer, but I'm trying to mount a module in /lib/modules on the installed system. So it's not the same version of the kernel ! And I can't mount the HFS partition. Second attempt: connect to the local network. From the chroot, transfer the vmlinux and initrd.gz files to a machine which has apache installed. Then reboot into MacOS 9.2, use a web browser to access the second machine, and download vmlinux and initrd.gz. Then in the future I can use these vmlinux and initrd.gz to boot into Debian GNU/Linux.

I really admire your creativity!  But the above magic is much easier...

debian-installer is for sure better than the "tools" you had to use to install Debian 3.0 on powerpc... But it seems there are still a few problems... Especially I don't see why MacOS 9.2 becomes unbootable after the installation of Debian GNU/Linux. Of course, I didn't touch the MacOS 9.2 partitions at all. I had a lot of spare space after the MacOS 9.2 partition, and I created my filesystems there. You can look at the output of mac-fdisk -l up there, I didn't mess with the Apple partitions :)


Reply to: