[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#413814: installing Debian GNU/Linux 4.0 on a Power Macintosh G3 Server

Package: installation-reports

Boot method: BootX
Image version: Debian etch powerpc weekly build
Date: February 4th 2007

Machine: Power Macintosh G3 Server
Architecture: powerpc
Processor: PowerPC 740/750 (G3)
Memory: 256 MB
Result of df -Tl:
Filesystem Type 1K-blocks Used Available Use% Mounted on
/dev/hda9 ext3 2883640 1201232 1535924 44% /
tmpfs tmpfs 119788 0 119788 0% /lib/init/rw
udev tmpfs 10240 96 10144 1% /dev
tmpfs tmpfs 119788 0 119788 0% /dev/shm
/dev/hda10 ext3 5291948 171180 4851944 4% /home
/dev/hda8 ext3 132385 26384 99166 22% /var/log
/dev/hda6 hfs 819182 364065 455117 45% /mnt/MacOS

Result of mac-fdisk -l:
# type name length base ( size ) system
/dev/hda1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map
/dev/hda2 Apple_Driver_ATA Macintosh 54 @ 64 ( 27.0k) Unknown
/dev/hda3 Apple_Driver_ATA Macintosh 74 @ 118 ( 37.0k) Unknown
/dev/hda4 Apple_Driver_IOKit Macintosh 512 @ 192 ( 256.0k) Unknown
/dev/hda5 Apple_Patches Patch Partition 512 @ 704 (256.0k) Unknown
/dev/hda6 Apple_HFS sans titre 1638400 @ 1216 (800.0M) HFS
/dev/hda7 Apple_UNIX_SVR2 swap 1015626 @ 1639616 ( 495.9M) Linux swap
/dev/hda8 Apple_UNIX_SVR2 untitled 273438 @ 2655242 (133.5M) Linux native
/dev/hda9 Apple_UNIX_SVR2 untitled 5859376 @ 2928680 ( 2.8G) Linux native
/dev/hda10 Apple_UNIX_SVR2 untitled 10753032 @ 8788056 ( 5.1G) Linux native

Block size=512, Number of Blocks=19541087
DeviceType=0x0, DeviceId=0x0
1: @ 64 for 21, type=0x701
2: @ 118 for 34, type=0xf8ff

Output of lspci -nn:
00:00.0 Host bridge [0600]: Motorola MPC106 [Grackle] [1057:0002] (rev 40)
00:10.0 Unknown class [ff00]: Apple Computer Inc. Heathrow Mac I/O [106b:0010] (rev 01)
00:12.0 VGA compatible controller [0300]: ATI Technologies Inc 3D Rage Pro 215GP [1002:4750] (rev 5c)

Output of lspci -vnn:
00:00.0 Host bridge [0600]: Motorola MPC106 [Grackle] [1057:0002] (rev 40)
Flags: bus master, fast devsel, latency 0

00:10.0 Unknown class [ff00]: Apple Computer Inc. Heathrow Mac I/O [106b:0010] (rev 01)
Flags: bus master, medium devsel, latency 32
Memory at f3000000 (32-bit, non-prefetchable) [size=512K]

00:12.0 VGA compatible controller [0300]: ATI Technologies Inc 3D Rage Pro 215GP [1002:4750] (rev 5c) (prog-if 00 [VGA])
Flags: bus master, stepping, medium devsel, latency 32, IRQ 22
Memory at 81000000 (32-bit, non-prefetchable) [size=16M]
I/O ports at fe000c00 [size=256]
Memory at 80800000 (32-bit, non-prefetchable) [size=4K]

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot: [O]
Detect network card: [O]
Configure network: [O]
Detect CD: [O]
Load installer modules: [O]
Detect hard drives: [O]
Partition hard drives: [O]

Install base system: [O]
Clock/timezone setup: [O]
User/password setup: [O]
Install tasks: [O]
Install boot loader: [E]
Overall install: [O]


Here's a feedback of my installation of Debian 4.0 "etch" on a Power Macintosh G3 MiniTower

Since it's an oldworld macintosh, it cannot boot from the Debian CDs. I tried booting from floppies, but it never worked, the floppy drive is probably dead.
So my solution was to install a legit copy of MacOS 9.2

Here's what I did:
- boot into MacOS 9.2
- launch BootX with the files vmlinux and initrd.gz
- debian-installer runs smoothly and everything goes well, except one thing: when debian-installer attempts to install quik as a boot loader, the operation fails, and the error messages states that "the partition is not ext2". This error messages seems odd to me. What partition does d-i mean ? The partition where MacOS 9.2 is, which is HFS ? One of the Linux partitions, which are ext3 and not ext2 ? Anyway, isn't ext2 the same thing as ext3 without journalization ?
- anyway I'm not worried at all that quik could not install, because I still can boot into MacOS 9.2 and then fire up BootX to boot into Debian GNU/Linux
- debian-installer finished up its work and reboots the machine
... and then something goes wrong: I see on the power macintosh a flashing "?" in a floppy. This means "I can't find any operating system to boot" ... ouch ! Now that's a problem.
- I tried zapping the PRAM, it did not help.
- Finally I took the "Outil Disque Dur" diskette and chose the menu "Fonction" and then "Mise à jour". Pardon my French, this should translate to "Apple Disk Tool", menu "Functions" and then "Update". I don't know the exact wording since I've never used MacOS 9.2 in any other language than French :)
... and *yes*, now I can boot into MacOS 9.2

... but now when I boot into Debian GNU/Linux with BootX, there is another, more serious problem:
When I boot into Debian GNU/Linux with BootX, I can only use the vmlinux and initrd.gz of debian-installer. So instead of booting into my system, I boot into debian-installer.
Attempt to solve this problem: start a shell from debian-installer, and chroot to my Debian GNU/Linux system. From there, find the vmlinux and initrd.gz that will allow me to boot directly into Debian GNU/Linux (they are in /boot) and make them accessible to the MacOS 9.2 system. But...
First attempt: mount the MacOS 9.2 (HFS) partition in read/write and copy vmlinux and initrd.gz there. The hfs driver isn't built in the kernel, so I need to load it with modprobe hfs... But alas ! It fails because it's not the same kernel version ! Indeed, I'm running the vmlinux kernel from debian-installer, but I'm trying to mount a module in /lib/modules on the installed system. So it's not the same version of the kernel ! And I can't mount the HFS partition.
Second attempt: connect to the local network. From the chroot, transfer the vmlinux and initrd.gz files to a machine which has apache installed. Then reboot into MacOS 9.2, use a web browser to access the second machine, and download vmlinux and initrd.gz. Then in the future I can use these vmlinux and initrd.gz to boot into Debian GNU/Linux.

debian-installer is for sure better than the "tools" you had to use to install Debian 3.0 on powerpc... But it seems there are still a few problems...
Especially I don't see why MacOS 9.2 becomes unbootable after the installation of Debian GNU/Linux. Of course, I didn't touch the MacOS 9.2 partitions at all. I had a lot of spare space after the MacOS 9.2 partition, and I created my filesystems there. You can look at the output of mac-fdisk -l up there, I didn't mess with the Apple partitions :)


Reply to: