[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#387855: LVM partitioner problems, sudo and user passwords problem

Package: installation-reports

Boot method: NetInstall CD.
Image version: etch beta 3
Date: 9/16/2006 9:10PM

Machine: Dell Dimension v4100
Processor: PIII 1GHz
Memory: 512MB
Partitions: <df -Tl will do; the raw partition table is preferred>

Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [ ] in progress
Install boot loader:    [ ]
Reboot:                 [ ]


I discovered on Friday afternoon that there was an IRC bot in /var/tmp 
on my Debian sid system, meaning I had been hacked somehow. I 
immediately set about reinstalling.

In my first attempt Friday afternoon, I decided to try some 
possibilities in the partitioner using LVM. I gave up fast, because I 
couldn't figure out how to resize the LVM partitions from the defaults 
the system gave me. I tried to use the guided partitioner to do a 
default partitioning scheme *without* LVM, but even then the LVM 
partitions continued to show up in the partitioner. I aborted at the 
installation (without ever confirming that anything should be written to 
disk), and found that the grub instance from the previous installation 
could no longer make it even to the menu.
IOW, the paritioner's LVM stuff is writing something to disk before 
asking confirmation. I gave up the installation becuase I didn't have 
enough time to finish. That was friday.

I started a new install Saturday night. The partitioner worked fine (I 
didn't try LVM this time), and didn't present any trace of LVM 
partitions. I encountered two other bugs in the installation: I was 
installing using a preseed file, (but not preseeding the actual 
installer, just the debconf for packages to be installed on the system) 
and somehow that causes the installer to return to the main menu after 
each step to ask you to select the next step. The other bug is at the 
point of creating users. It asked me whether I wanted to configure the 
root on that system for sudo. I answered yes, it complained about a 
blank password, and then asked me to enter "the password for the new 
user" without ever asking me a username, or telling me that I was really 
entering a root password. I tried that step again, this time without 
sudo, and it asked me for "a password for the new user" (who I assume 
must be root), but never asked me to create a new user account for a 
normal user.

I'm now waiting for the installer to download and install packages, and 
hopefully I'll be able to finish the installation before 11:00pm (so 
that I can tell it to download a *much larger* collection of packages 

I'll follow up to this bug report with any problems in the rest of the 
install (and also the missing fields in the above form).

Ken Bloom. PhD candidate. Linguistic Cognition Laboratory.
Department of Computer Science. Illinois Institute of Technology.

Reply to: