[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#387855: LVM partitioner problems, sudo and user passwords problem

clone 387855 -1
reassign -1 user-setup
retitle -1 Incorrect behavior when changing from sudo to non-sudo setup

On Sunday 17 September 2006 04:26, Ken Bloom wrote:
> In my first attempt Friday afternoon, I decided to try some
> possibilities in the partitioner using LVM. I gave up fast, because I
> couldn't figure out how to resize the LVM partitions from the defaults
> the system gave me. I tried to use the guided partitioner to do a
> default partitioning scheme *without* LVM, but even then the LVM
> partitions continued to show up in the partitioner.

The current daily builds have added functionality that deletes existing 
LVM when auto-partitioning a disk.

> I aborted at the 
> installation (without ever confirming that anything should be written
> to disk), and found that the grub instance from the previous
> installation could no longer make it even to the menu.
> IOW, the paritioner's LVM stuff is writing something to disk before
> asking confirmation.

This is a known issue. See http://bugs.debian.org/368633. I hope to work 
on this soon.

> I started a new install Saturday night. The partitioner worked fine (I
> didn't try LVM this time), and didn't present any trace of LVM
> partitions. I encountered two other bugs in the installation: I was
> installing using a preseed file, (but not preseeding the actual
> installer, just the debconf for packages to be installed on the system)
> and somehow that causes the installer to return to the main menu after
> each step to ask you to select the next step.

This means that an error occurred which causes the "priority" to be 
lowered which results in the menu being displayed. The syslog for the 
installation should show where the error occurred.

> The other bug is at the 
> point of creating users. It asked me whether I wanted to configure the
> root on that system for sudo. I answered yes, it complained about a
> blank password, and then asked me to enter "the password for the new
> user" without ever asking me a username, or telling me that I was
> really entering a root password. I tried that step again, this time
> without sudo, and it asked me for "a password for the new user" (who I
> assume must be root), but never asked me to create a new user account
> for a normal user.

I was able to reproduce this behavior and will clone this report to the 
relevant package.

On Sunday 17 September 2006 05:54, Ken Bloom wrote:
> The installer asked a number of debconf questions that I would have
> expected to be preseeded (probably becuase I didn't specify
> debian/priority=critical)

Possible. Or because the priority was lowered because of the error that 

> Installing the bootloader failed. The installer didn't
> create a /boot/grub/menu.lst, so it couldn't install GRUB.

This is a known issue due to a change in grub and is being worked on.
Creating a symlink in /target/sbin for /target/usr/sbin/grub-install 
should allow grub-installer to work.

> When I booted into the system (after manually installing GRUB), the
> system had a user account for me (apparently, it got that from the
> preseed), but root was set to sudo (even though in the end, I had
> asked it not to do that). I had to reboot from a boot CD and poke
> around in /etc/passwd and /etc/shadow in order to figure that out.

Probably a result of the problems in the user-setup dialogs you mentioned 


Reply to: