[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#379067: couple of minor glitches in install of powerpc

On Jul 22, 2006, at 6:11 AM, Jens Seidel wrote:
On Sat, Jul 22, 2006 at 05:59:02AM -0400, Rick Thomas wrote:
so it hung.  (Does hanging if the CD is not inserted count as a bug?)

It depends on the kind of "hanging". If APT just asks you to insert a
special CD I think this is OK and expected.

If you do not get such an prompt it is definitively a bug!

As part of a different report [Bug#379365: Semi-successful install with miBoot floppy set and Netinst CD on OldWorld Mac...] I did some experiments that may be helpful in figuring out what's going on here...

I did a "bare bones" install (un-checked the "Desktop" task in the task selection stage) from a netinst CD today. As part of the finish- up/reboot stage, I removed the netinst install CD from the drive as instructed. After the reboot, I tried to use tasksel to install the missing Desktop task. I deliberately left the CD out of the drive. I got these messages on the console:

> HASH (0x101a4004) provides: complete-desktop
> E: Package read-edid has no installation candidate
> cdrom: open failed
> cdrom: open failed

Then the process hung. I hit ctl-C as an experiment, and it proceeded a bit, but gave two more messages "cdrom: open failed" and hung again. Hitting ctl-C again did not make it progress any further.

I went to another console window and rebooted. After the reboot, I tried tasksel again, but this time with the CD in the drive. It ran just fine, but it did *not* read much (if anything at all) from the CDrom -- no blinking lights that I could see on the CD drive -- but lots of network activity. Very curious!

Later on, I tried "mount -v /media/cdrom" with no CD in the drive. I got the message "mount: No medium found" on the console. So the drive (and the driver) is doing it's job and reporting correctly that there is no media in the drive.

Then I used aptitude to install the "openssh" package. I did it with nothing in the CD drive. Aptitude gave me an error message: > Please insert the disk labeled "Debian GNU/Linux testing _Etch_ ..." into the drive "/cdrom".
> [continue]     [abort]

I chose [abort] and it went ahead and got the package from the network server.

So there seems to be a difference between "tasksel" and "aptitude" in their behavior on a missing CDrom. In an earlier part of this report I said that "aptitude" had hung. I believe now that it was actually "tasksel" that hung. Sorry for any confusion this may have caused.

Hope this helps!


Reply to: