[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#323182: debian-installer: boot.img for sarge doesn't, on PPC

On Mon, Aug 15, 2005 at 06:13:12PM +0200, Geert Stappers wrote:
> severity 323182 normal
> thanks mate
> On Mon, Aug 15, 2005 at 05:46:11AM -0400, Simon Raven wrote:
> > Package: debian-installer
> > Severity: grave
> > Justification: renders package unusable
> The debian installer works on systems where we[1] have acces to.
> > boot.img for sarge on powerpc doesn't boot, no matter what i do, what
> > date i get it from (there's a 20041118/ dir on the site, tried those,
> > doesn't want to boot either). i've tried both 2.4 and 2.6 floppies, any
> > machine i stick it in spits it back out without any warning and pops up
> > a floppy picture with a big X in it. i've tried it with several
> > downloads and several floppies, all known good, and they just don't
> > boot, no matter what i do. the bootx option is not possible at this
> > point in time as i have no bin to store the drive with mock os on it
> > anywhere, and i shouldn't have to do this on a known otherwise working
> > machine with sarge on it, with a dead battery, and the other a sid install,
> > been running since late 2002 (potato->woody).
> > 
> > i'm trying to rescue these 2 ppc oldworld macs, and without a working boot.img,
> > i cannot rescue them at all.
> I have seen reports of succesfull installs on PowerPC hardware
> on the debian-boot mailinglist.  I have not clear how they boot.
> It could be a Mac OS boot CD-ROM and some bootstrap.
> Please report your progress on the rescue of PowerPC hardware.

Ok, please ignore my previous mail, it is stupid.

The boot.img are the miboot floppies for oldworld pmacs. These are saddly not
useable in sarge, because miboot is non-free (due to the one boot block which
is coming directly from apple and has a couple tens of m68k assembly
instructions nobody could be bothered to reverse-enginneer).

As a result, the floppies present in sarge are entirely broken and will never
work. Also the 2.6 floppies, even with miboot present never worked fiably,
annd since we are doing away with the 2.4 kernels for etch, this means that
the miboot floppy target is going away then.

Anyway, please try some of the older daily builds found on my site :


Chose a date, and go to powerpc/floppy-2.4 to find something working.

Again, sorry for my other stupid mail, and test these ones.

Maybe i should build a couple of miboot floppies accompanying the official
release ?


Sven Luther

Reply to: